Build: #301 failed

Job: Run deprecated integration tests failed

Job result summary

Completed
Duration
1 minute
Revision
808f8d1d1c4c46f1de208e6f2473eb9823e5bafb 808f8d1d1c4c46f1de208e6f2473eb9823e5bafb
Failing since
#297 (Code changes detected – )
Fixed in
#306 (Manual run by Rafal Korytkowski)
No failed test found. A possible compilation error occurred.

Error summary

The build generated some errors. See the full build log for more details.

+ export OCLAPI_IMAGE_ID=openconceptlab/oclapi@sha256:fd58b29c36d1ce894c1fb42488be130cb33b6254cd5d14519bc19ed616835fcc
+ OCLAPI_IMAGE_ID=openconceptlab/oclapi@sha256:fd58b29c36d1ce894c1fb42488be130cb33b6254cd5d14519bc19ed616835fcc
+ export OCLSOLR_IMAGE_ID=openconceptlab/oclsolr@sha256:ec7d6d8b9ba1407f132588be9d2d0cbd47da806321710da64a75e6bb6a2d04cd
+ OCLSOLR_IMAGE_ID=openconceptlab/oclsolr@sha256:ec7d6d8b9ba1407f132588be9d2d0cbd47da806321710da64a75e6bb6a2d04cd
+ docker-compose -f docker-compose.yml -f docker-compose.ci.yml run --rm api python manage.py test integration_tests --configuration=Dev
Creating network "ocl-oa-rit_default" with the default driver
Creating volume "ocl-oa-rit_mongo_data" with default driver
Creating volume "ocl-oa-rit_solr_data" with default driver
Pulling solr (openconceptlab/oclsolr@sha256:ec7d6d8b9ba1407f132588be9d2d0cbd47da806321710da64a75e6bb6a2d04cd)...
Pulling mongo (mongo:3.2.11)...
Pulling redis (redis:3.2.10)...
Creating ocl-oa-rit_redis_1 ...
Creating ocl-oa-rit_mongo_1 ...
Creating ocl-oa-rit_solr_1  ...

Creating ocl-oa-rit_redis_1 ... done

Creating ocl-oa-rit_mongo_1 ... done

Creating ocl-oa-rit_solr_1  ... done
Pulling api (openconceptlab/oclapi@sha256:fd58b29c36d1ce894c1fb42488be130cb33b6254cd5d14519bc19ed616835fcc)...
INFO 2020/01/28 14:16:58 [base.py:220 __init__()] Raven is not configured (logging is disabled). Please see the documentation for more information.
/usr/local/lib/python2.7/site-packages/django_mongodb_engine/creation.py:98: DeprecationWarning: 'descending_indexes', 'sparse_indexes' and 'index_together' are deprecated and will be ignored as of version 0.6. Use 'indexes' instead.
  "Use 'indexes' instead.", DeprecationWarning)

WARNING 2020/01/28 14:16:59 [creation.py:98 _handle_oldstyle_indexes()] /usr/local/lib/python2.7/site-packages/django_mongodb_engine/creation.py:98: DeprecationWarning: 'descending_indexes', 'sparse_indexes' and 'index_together' are deprecated and will be ignored as of version 0.6. Use 'indexes' instead.
  "Use 'indexes' instead.", DeprecationWarning)

FieldDoesNotExist: ConceptVersion has no field named 'previous_version_id'
+ docker-compose down -v
Stopping ocl-oa-rit_mongo_1 ...
Stopping ocl-oa-rit_solr_1  ...
Stopping ocl-oa-rit_redis_1 ...

Stopping ocl-oa-rit_redis_1 ... done

Stopping ocl-oa-rit_mongo_1 ... done

Stopping ocl-oa-rit_solr_1  ... done
Removing ocl-oa-rit_mongo_1 ...
Removing ocl-oa-rit_solr_1  ...
Removing ocl-oa-rit_redis_1 ...

Removing ocl-oa-rit_redis_1 ... done

Removing ocl-oa-rit_solr_1  ... done

Removing ocl-oa-rit_mongo_1 ... done
Removing network ocl-oa-rit_default
Removing volume ocl-oa-rit_mongo_data
Removing volume ocl-oa-rit_solr_data