Build: #373 failed Manual run by Rafal Korytkowski

Stages & jobs

  1. Default Stage

  2. QA

Build result summary

Details

Completed
Duration
1 minute
Labels
None
Revision
8a99f394f01ff64aa89051bad00eb11c12154f74 8a99f394f01ff64aa89051bad00eb11c12154f74
Fixed in
#376 (Manual run by Cintia Del Rio)
No failed test found. A possible compilation error occurred.

Responsible

No one has taken responsibility for this failure

Error summary for Default Job

The job generated some errors, drill down into the full build log for more details.

npm WARN deprecated browserslist@2.11.3: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm WARN deprecated sw-precache@5.2.1: Please migrate to Workbox: https://developers.google.com/web/tools/workbox/guides/migrations/migrate-from-sw
npm WARN deprecated sw-toolbox@3.6.0: Please migrate to Workbox: https://developers.google.com/web/tools/workbox/guides/migrations/migrate-from-sw
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN bootstrap@4.3.1 requires a peer of jquery@1.9.1 - 3 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@2.1.0 requires a peer of babel-eslint@^7.2.3 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@2.1.0 requires a peer of eslint@^4.1.1 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@2.1.0 requires a peer of eslint-plugin-jsx-a11y@^5.1.1 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-loader@1.9.0 requires a peer of eslint@>=1.6.0 <5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN ajv-keywords@3.4.0 requires a peer of ajv@^6.9.1 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.7 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.7: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

PASS  src/tests/dictionaryConcepts/container/CreateConcept.test.jsx (7.748s)
PASS  src/tests/dictionaryConcepts/container/EditConcept.test.jsx (5.091s)
PASS  src/tests/dictionaryConcepts/actions/dictionaryConcept.test.js
PASS  src/tests/Dashboard/container/OwnerDisplay.test.jsx
PASS  src/tests/Dashboard/action/dictionaryAction.test.js
PASS  src/tests/Dashboard/container/DictionaryDisplay.test.jsx
PASS  src/tests/Dictionary/ListDictionaries.test.jsx
PASS  src/tests/Dictionary/DictionaryContainer.test.jsx
PASS  src/tests/dictionaryConcepts/container/DictionaryConcepts.test.jsx

/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-scripts/scripts/test.js:20
  throw err;
  ^
Invariant Violation: The `document` global was defined when React was initialized, but is not defined anymore. This can happen in a test environment if a component schedules an update from an asynchronous callback, but the test has already finished running. To solve this, you can either unmount the component at the end of your test (and ensure that any asynchronous operations get canceled in `componentWillUnmount`), or you can change the test itself to be asynchronous.
    at invariant (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:55:15)
    at Object.invokeGuardedCallbackDev (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:110:44)
    at invokeGuardedCallback (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:256:31)
    at commitRoot (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:18881:7)
    at /home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:20418:5
    at Object.unstable_runWithPriority (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/scheduler/cjs/scheduler.development.js:255:12)
    at completeRoot (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:20417:13)
    at performWorkOnRoot (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:20346:9)
    at performWork (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:20254:7)
    at performSyncWork (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:20228:3)
    at requestWork (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:20097:5)
    at scheduleWork (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:19911:5)
    at Object.enqueueSetState (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react-dom/cjs/react-dom.development.js:11169:5)
    at CreateMapping.Object.<anonymous>.Component.setState (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/node_modules/react/cjs/react.development.js:335:16)
    at CreateMapping.<anonymous> (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/src/components/dictionaryConcepts/components/CreateMapping.jsx:54:43)
    at next (native)
    at step (/home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/src/components/dictionaryConcepts/components/CreateMapping.jsx:10:416)
    at /home/bamboo-agent/bamboo-agent/xml-data/build-dir/OCL-OC-JOB1/src/components/dictionaryConcepts/components/CreateMapping.jsx:10:576
    at process._tickCallback (internal/process/next_tick.js:109:7)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! openmrs-ocl-client@0.1.0 test:bamboo: `react-scripts test --env=jsdom -u --ci --coverage --testResultsProcessor ./node_modules/jest-junit`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the openmrs-ocl-client@0.1.0 test:bamboo script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/bamboo-agent/.npm/_logs/2019-04-15T09_50_22_623Z-debug.log