Build: #722 was successful

Job: Test, build and push docker image was successful

Stages & jobs

  1. Default Stage

  2. QA

Job result summary

Completed
Duration
27 minutes
Agent
yokobue.openmrs.org
Revision
823d76cdaee8e14708251ca9b115ebf13dc9beae 823d76cdaee8e14708251ca9b115ebf13dc9beae
Total tests
3
First to pass since
#719 (Code changes detected – )
Number of retries
2

Tests

  • 3 tests in total
  • < 1 second taken in total.

Error summary

The build generated some errors. See the full build log for more details.

v12.22.1 is already installed.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/webpack-dev-server/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchpack-chokidar2/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/watchify/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/cypress-cucumber-preprocessor/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules/babel-plugin-add-module-exports/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

PASS src/utils/tests/unit/utils.test.ts
PASS src/tests/unit/App.test.tsx (21.418 s)

Test Suites: 2 passed, 2 total
Tests:       3 passed, 3 total
Snapshots:   0 total
Time:        25.673 s
Ran all test suites matching /.*\/tests\/unit\//i.
Creating network "oclapi_default" with the default driver
Pulling mongo (mongo:3.2.11)...
Pulling redis (redis:3.2.10)...
Pulling solr (openconceptlab/oclsolr:production)...
Building api
Image for service api was built because it did not already exist. To rebuild this image you must use `docker-compose build` or `docker-compose up --build`.
Creating oclapi_solr_1 ...
Creating oclapi_redis_1 ...
Creating oclapi_mongo_1 ...

Creating oclapi_solr_1  ... done

Creating oclapi_mongo_1 ... done

Creating oclapi_redis_1 ... done
Creating oclapi_api_1   ...

Creating oclapi_api_1   ... done
Building oclclient
Creating network "ocl-oc-job1_default" with the default driver
Creating ocl-oc-job1_oclclient_1 ...

Creating ocl-oc-job1_oclclient_1 ... done
resize:  can't open terminal /dev/tty
tput: No value for $TERM and no -T specified
resize:  can't open terminal /dev/tty
tput: No value for $TERM and no -T specified
+ docker --version
+ docker login -u openmrsci -p ********
WARNING! Using --password via the CLI is insecure. Use --password-stdin.
WARNING! Your password will be stored unencrypted in /home/bamboo-agent/.docker/config.json.
Configure a credential helper to remove this warning. See
https://docs.docker.com/engine/reference/commandline/login/#credentials-store

+ IMAGE=openmrs/ocl-client
+ TAG=latest
+ /usr/bin/docker build --force-rm=true --tag=openmrs/ocl-client:latest --build-arg OCL_BUILD=722 --file docker/Dockerfile .
+ docker push openmrs/ocl-client:latest
+ docker image inspect '--format={{index .RepoDigests 0}}' openmrs/ocl-client:latest