Build #1,950

Deploys Reference Application SNAPSHOT to maven

Build: #1950 failed Child of RDD-RDD-564

Stages & jobs

  1. Create Reference Application packages

  2. Deploy to Automated Functional Test Server

  3. Create Standalone and Run UI Tests

  4. Deploy to Manual Test Server

Logs

The following logs have been generated by the jobs in this plan.
  • Expand all
  • Collapse all
Job Logs
Collapse Run UI tests on Travis Create Standalone and Run UI Tests Download or View
23-Apr-2014 16:35:37
23-Apr-2014 16:35:37 Results :
23-Apr-2014 16:35:37
23-Apr-2014 16:35:37 Failed tests:   verifyNurseModulesAvailableOnHomePage(org.openmrs.reference.LoginTest): expected:</openmrs/[login.htm]> but was:</openmrs/[initialsetup]>
23-Apr-2014 16:35:37   verifyModulesAvailableOnHomePage(org.openmrs.reference.LoginTest): expected:</openmrs/[login.htm]> but was:</openmrs/[initialsetup]>
23-Apr-2014 16:35:37   verifyClerkModulesAvailableOnHomePage(org.openmrs.reference.LoginTest): expected:</openmrs/[login.htm]> but was:</openmrs/[initialsetup]>
23-Apr-2014 16:35:37   verifyDoctorModulesAvailableOnHomePage(org.openmrs.reference.LoginTest): expected:</openmrs/[login.htm]> but was:</openmrs/[initialsetup]>
23-Apr-2014 16:35:37   checkModules(org.openmrs.reference.CheckModules): expected:</openmrs/[login.htm]> but was:</openmrs/[initialsetup]>
23-Apr-2014 16:35:37   registerAPatient(org.openmrs.reference.RegistrationAppTest): expected:</openmrs/[login.htm]> but was:</openmrs/[initialsetup]>
23-Apr-2014 16:35:37
23-Apr-2014 16:35:37 Tests in error:
23-Apr-2014 16:35:37   registerAPatient(org.openmrs.reference.RegistrationAppTest): Timed out after 8 seconds waiting for presence of element located by: By.xpath: //a[@href='/openmrs/logout'](..)
23-Apr-2014 16:35:37   testStartVisit(org.openmrs.reference.VisitTest)
23-Apr-2014 16:35:37   testStartVisit(org.openmrs.reference.VisitTest)
23-Apr-2014 16:35:37
23-Apr-2014 16:35:37 Tests run: 9, Failures: 6, Errors: 3, Skipped: 0
23-Apr-2014 16:35:37
23-Apr-2014 16:35:37 [WARNING] File encoding has not been set, using platform encoding UTF-8, i.e. build is platform dependent!
23-Apr-2014 16:35:37 [INFO] ------------------------------------------------------------------------
23-Apr-2014 16:35:37 [INFO] BUILD SUCCESSFUL
23-Apr-2014 16:35:37 [INFO] ------------------------------------------------------------------------
23-Apr-2014 16:35:37 [INFO] Total time: 57 seconds
23-Apr-2014 16:35:37 [INFO] Finished at: Wed Apr 23 16:35:37 EDT 2014
23-Apr-2014 16:35:37 [INFO] Final Memory: 60M/316M
23-Apr-2014 16:35:37 [INFO] ------------------------------------------------------------------------